Hades Kurzanleitung und Referenzkarte

Hades ist ein Framework zur interaktiven
Simulation mit vordefinierten Komponenten.
Fur die Simulation digitaler Schaltungen ste-
hen derzeit etwa 200 Simulationsmodel-
le zur Verfigung, von einfachen Grundgat-
tern und Flipflops Uber RT-Modelle bis zum
MIPS R3000 Mikroprozessor. Diese Simu-
lationsmodelle verwenden das neunwertige
std_logic-Logikmodel, so dass auch Busse
modelliert werden kénnen.

Weitere Informationen, Updates, und Do-
kumentation sind Uber die Hades Home-
page verfuigbar: tech-www.informatik.uni-
hamburg.de/applets/hades/

Download und Installation

Das Hades Framework ist als pure-Java
Programm geschrieben und erfordert min-
destens eine Java 1.1 Laufzeitumgebung.
Empfehlenswert sind JDK 1.3.1 oder die ak-
tuelle Microsoft VM (3.318 oder hoher).
Schritt 1 : Sofern Sie nicht eine angepas-
ste Version von Hades bendtigen, laden Sie
bitte die Archiv-Datei hades.zip von der
Hades Homepage herunter, die die gesam-
te Software mit allen Java-Klassen und Re-
sourcen enthalt.

Schritt 2 : Benennen Sie das hades.zip-
Archiv nach hades. jar um.

Schritt 3: Erzeugen Sie ein neues Ver-
zeichnis fur Hades und verschieben Sie
die hades.jar Datei dorthin. Lesen Sie
im Hades-Tutorial nach, welche Verzeich-
nisstruktur gunstig ist. Hier ein Beispiel:

C:\users\hugo\hades
C:\users\hugo\hades\hades. jar
C:\users\hugo\hades\examples\

Zum Starten des Hades Editors und Simula-
tors unter JDK 1.3 und Windows genugt es,
die hades.jar Datei doppelzuklicken. Al-
ternativ und auf anderen Betriebssystemen
offnen Sie eine Command-Shell, wechseln
in das Verzeichnis mit dem hades. jar Ar-
chiv, und verwenden den folgenden Befehl:

java -jar hades.jar
Mit der Microsoft VM lautet der Befehl:
jview /cp hades.jar hades.gui.Editor

Abhangig vom Betriebssystem und Version
der JVM ist es eventuell notwendig, der JVM
einige Optionen zu Ubergeben. Auch der
Hades-Editor selbst unterstiitzt einige Be-
fehlszeilenoptionen. Zum Beispiel:

java -Xmx256m -jar hades.jar
java -jar hades.jar -file latch.hds

Neben dem Editor sind noch viele weitere
Java-Klassen im hades. jar Archiv als ei-
genstandige Programme nutzbar, z.B.:

setenv CLASSPATH hades.jar
java hades.models.pic.PicAssembler
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Editor und Simulation

Die obige Abbildung zeigt das User-Inter-
face des Hades-Editors mit Mendileiste und
dem zentralen Graphikeditor mit seinem
Popup-Meni. Am unteren Rand des Edi-
tors befinden sich die Bedienelemente zur
Steuerung des Simulators. Mit den Default-
Einstellungen wird der Simulator beim Start
des Editors oder beim Laden einer Schal-
tung automatisch gestartet, was in der Am-
pel durch die grine LED angezeigt wird.
Analog bedeutet rot angehalten und gelb-
Pause:

<< rewind stoppt die aktuelle Simula-
tion endglltig. Es kann aber jeder-
zeit mit run eine neue Simulation
gestartet werden.

pause unterbricht die Simulation,
erlaubt aber die Fortsetzung.

run startet die Simulation.

run interval simuliert fiir das im ne-
benstehenden Textfeld angegebe-
ne Zeitintervall und wechselt dann
in den Zustand pause
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Uber das Auswahlmenii kdnnen verschie-
dene Simulatoren ausgewahlt werden, die
sich in ihrem Zeitverhalten unterscheiden.
Fur die interaktive Simulation ist die Einstel-
lung VHDL empfehlenswert.

Laden und Speichern

Mit Hades erstellte Schaltungen werden als
normale Textdateien gespeichert, die bei
Bedarf auch mit jedem Texteitor bearbeitet
werden konnen. Diese Dateien sollten per
Konvention die Endung . hds erhalten.
Uber das File-Menii des Editors erreichen
Sie die ublichen Funktionen:

New  Neustart mit leerem Editor
Open Offnet ein Hades-Design.
Save Speichert die aktuelle Schaltung;

dabei wird die bisherige Version

umbenannt, * .hds_0, .hds_1 usw.
Save as Speichert die aktuelle Schaltung

unter dem ausgewahlten Namen

Exit Beendet den Editor
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Anzeige, Zoom, Magnetic Grid

Die Graphikdarstellung im Editor kann tber
die Window und Display Menus angepasst
werden. Window>ZoomFit zeigt die ak-
tuelle Schaltung vollstandig an. Mit Win-
dowrZoom Region kann ein Ausschnitt ge-
wahlt werden.

Uber Window >Magnetic Grid lassen sich
die moglichen Objektpositionen einschrén-
ken. Fur die meisten Simulationsmodelle
ist 1/4 inch ginstig, aber einige Objekte
bendtigen die 1/8 inch Einstellung. Die Bild-
wiederholfrequenz wahrend der Simulation
kann mit Window> Selectrepaint fregency
gewahlt werden.

Glow-Mode

Optional (Uber Display>glowmode) kann
der Editor wahrend der Simulation direkt die
Werte auf den Leitungen anzeigen:

grau  0-Pegel (0 Volt, Masse)
rot 1-Pegel (5 Volt)

orange Z, hochohmig, offen

cyan X, undefiniert, Kurzschluss
magenta U, nicht initialisiert

Popup-Menti

Das Popup-Menii auf der zentralen Editor-
flache ist ein wichtiges Bedienungselement
fir Hades; so sind alle wichtigen Funktionen
zum Erzeugen und Editieren von Kompo-
nenten und deren Verbindungen unterein-
ander Uber das Popup-Menii zu erreichen.
Auf Windows- und Unix-Rechnern wird das
Popup-Menl mit der rechten Maustaste ak-
tiviert. Um eine mdoglichst effiziente Bedie-
nung zu erreichen, beziehen sich die Aktio-
nen dabei automatisch auf die Komponente
an der jeweiligen Mausposition.

Komponenten erzeugen

Jede Simulation in Hades verwendet vorde-
finierte Simulationsmodelle, die dann geeig-
net miteinander verbunden werden. Diese
Komponenten werden am einfachsten tber
die Untermenlis von PopuprCreate aus-
gewahlt. In der Abbildung oben links wird
gerade ein NAND2-Gatter selektiert. Das
Popup-Meni wird beim Start des Editors dy-
namisch erzeugt; abhangig von den Einstel-
lungen und der jeweils verwendeten Version
kénnen die Eintrége variieren.

Gatter, Flipflops, usw.

Die Untermenus unter PopuptrCreate er-
lauben direkten Zugriff auf haufig benétig-
te Simulationsmodelle. Zum Beispiel enthal-
ten die Untermeniis Popup > Create > Gates
bzw. > Gatter die einfachen Logikgatter wie
Inverter, AND, NAND, OR, NOR, XOR mit



zwei bis vier Eingangen, Multiplexer und
Tristate-Treiber.

Uber Popup > Create > Flipflops sind Flip-
flops und Latches zuganglich. Je nach Ver-
sion sind einige der Flipflops moglicher-
weise deaktiviert, um einen sauberen Ent-
wurfsstil zu erzwingen.

I/O Komponenten

Das Untermeni Popup > Create > 1O enthalt
interaktive 1/0-Komponenten:
Ipin Schalter zur Dateneingabe. Beim
Anklicken des Schalters wechselt
der Ausgangswert zwischen den
Werten 0/1; bei gedriickter SHIFT-
Taste wird 0/1/X/U erzeugt.
Leuchtdiode und Schaltungsaus-
gang (Hierarchiekonnektor).
LED Leuchtdiode (Farbe einstellbar).
ClockGen Taktgenerator (einstellbar).
PowerOnReset Resetimpulsgenerator
HexSwitch Schalter zur Dateineingabe der
4-bit Werte {0. .F}.
HexDisplay Anzeige fur 4-bit Werte {0. .F}.
VCC logische 1 (Betriebsspannung).
GND logische 0 (Masse).
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Subdesigns und Hierarchie

Jede Schaltung kann in Hades als Teil-
komponente in Ubergeordneten hierarchi-
schen Designs eingesetzt werden. Das da-
zu bendtigte graphische Symbol erzeu-
gen Sie mittels Menu>Edit>Create Sym-
bol. Uber Popup > Create > Subdesign kann
das Subdesign dann in das aktuelle Design
eingefugt werden.

Uber die Funktion Popup Createrby na-
me kdnnen beliebige weitere Simulations-
komponenten Uber ihren Java Klassenna-
men aufgerufen werden, zum Beispiel ha-
des.models.gates.Nand2.

Komponenten editieren

Das Popup-Menl dient auch dazu, vorhan-
dene Komponenten zu editieren. Um ei-
ne moglichst effiziente Bedienung zu errei-
chen, beziehen sich die Aktionen dabei wie-
derum direkt auf die Komponente an der ak-
tuellen Mausposition:

Name Umbenennen,

Move Verschieben,

Copy Kopieren,

Edit  Offnet den zugehérigen Property-
Editor zum Einstellen der Parame-
ter,

Delete Loschen der Komponente.

Dréahte erzeugen

Nach dem Erzeugen der bendtigten Kompo-
nenten missen diese miteinander ,verdrah-
tet’ werden. Fast alle Befehle zur Verdrah-
tung sind im Popup>Wire Meni enthalten.
Fur schnelleren Zugriff empfehlen sich je-
doch die Tastatur-Shortcuts (s.u.).

Um einen neuen Draht zwischen zwei freien
Anschliissen (,Ports*) zu erzeugen, klicken

Sie einfach auf den ersten dieser An-
schliisse, und Hades erzeugt einen neu-
en Draht (,Signal*). Klicken Sie anschlies-
send auf alle bendtigten Zwischenpunkte
und dann auf den zweiten Anschluss. Das
Signal wird sofort erzeugt und in die inter-
nen Datenstrukturen des Editors aufgenom-
men. Mit dem nachsten Mausklick kann so-
fort der nachste Draht gelegt werden.

Um eine Abzweigung an einen bestehen-
den Draht anzuschliessen, bewegen Sie die
Maus zur gewlinschten Abzweigeposition
und wahlen Sie dann das Kommando Po-
pup > Wire >add segment oder die Shortcut-
Taste ,w*. Klicken Sie wiederum auf alle
gewunschen Zwischenpunkte und dann den
Zielanschluss.

Drahte editieren

Wahlen Sie Popup>Wire>delete, um das
Signal an der Mausposition komplett zu
loschen. Einzelne Segmente kdnnen mit
Popup > Wire > delete segment (shortcut ,x*)
geldscht werden, wobei der Draht evtl. in
mehrere Einzeldrahte aufgespalten wird.
Bewegen Sie die Maus auf einen Eck-
punkt eines Signals und wahlen Sie Po-
pup > Wire >move point (bzw. ,0"), um die-
sen Eckpunkt zu verschieben.

Drahte miteinander verbinden

Um zwei Drahte miteinander zu verbinden,
erzeugen/erweitern Sie den ersten Draht
wie oben beschrieben. Um die Verbindung
zu erzwingen, halten Sie die SHIFT-Taste
gedruckt und klicken Sie dann auf einen
Eckpunkt des zweiten Drahtes.

Impulsdiagramme

Hades protokolliert Signalverlaufe nur, wenn
vorher ,probes* an diesen Signalen ange-
bracht wurden. Signals>Add Probes erlaubt
die Auswahl von Signalgruppen. Probes fir
einzelne Signale kénnen mit den Shortcut-
Tasten ,p* und ,P“ erzeugt bzw. geléscht
werden. Mit Signals> Show Waves wird das
Impulsdiagrammfenster angezeigt, und je-
weils nach Anklicken von Zoom 1:1 aktua-
lisiert.

Cancel, Undo, Redo

Wabhlen Sie Edit> Cancel oder driicken Sie
die ESCAPE-Taste, um ein beliebiges Kom-
mando abzubrechen. Viele Befehle kdnnen
mit Edit> Undo zurlickgenommen oder mit
Redo neu ausgefihrt werden.

Befehlstasten

Viele Befehle lassen sich statt (iber die
Menis wesentlich effizienter Uber Short-
cut Tastenkirzel aufrufen (wenn der Editor
den Tastaturfokus besitzt). Die wichtigsten
Shortcut-Tasten:

ESC Cancel, Befehl abbrechen
DEL,BS Loéschen (Komponente, Signal)

n Name (Komponente)

m Move (Komponente)
C Copy (Komponente)
e Edit (Komponente)
N Name (Signal)

w neues Segment (Abzweigung)
Y Vertex einfligen

o] Vertex verschieben
X Segment l6schen

0 Signal auf 0 setzen
1 Signal auf 1 setzen
u Signal auf U setzen
p.P add/remove probe

g Glow mode on/off

f,1 Zoom fit, 100 %

z,Z Zoom out, Zoom in

CNTL-2,4,8,6 magnetic grid 1/2, 1/4, 1/8,
1/16 inch (Cursorpositionen)

Konfiguration

Viele Eigenschaften des Hades Editors und
Simulators kdnnen Uber Properties Varia-
blen eingestellt werden. Dazu liest der Edi-
tor beim Start zunachst die Defaultwerte
aus /hades/.hadesrc im hades. jar Archiv,
und dann nacheinander die .hadesrc Datei-
en in lhrem Homeverzeichnis und dem aktu-
ellen Arbeitsverzeichnis.

Um die Einstellungen zu Uberprifen, rufen
Sie im Meni einfach Special > Show proper-
ties auf. Andern Sie im Textfeld alle Werte
nach Ihren Wiinschen, und klicken Sie dann
den Save as <home>/.hadesrc oder Save
as local .hadesrc Button an, um diese Wer-
te abzuspeichern. Alternativ kdnnen Sie die
.hadesrc-Dateien auch direkt mit einem
Texteditor &ndern. Achtung: Die Anderun-
gen werden erst beim nachsten Start des
Editors wirksam.

Tips und Features

Fehlende Lotstellen Der Hades Editor ver-
bindet Leitungen nicht automa-
tisch mit Komponenten. Verwenden
Sie die Popup > Wire > Autoconnect
Funktion, um eine Komponente mit
allen passenden Drahtenden zu
verbinden.

Tooltips Aufgrund von Bugs im Java-AWT
bekommen die Tooltip-Fenster au-
tomatisch den Fokus. Dies kann
gerade unter Windows stark beim
Editieren storen. Dekativieren Sie
die Tooltips bei Bedarf uUber Dis-
play > Enable Tooltips.

Editor hangt Beachten Sie die Statuszeile
oben im Editor, um zu Uberpriifen,
ob Hades eine Eingabe erwartet.
Drucken Sie die ESC-Taste, um
den aktiven Befehl abzubrechen.

Undefinierte Signale Viele Simulationsmo-
delle missen explizit initialisiert
werden (,reset*), andere sind nur
beim Start der Simulation aktiv.
Dies gilt insbesondere fiir die VCC-
und GND-Komponenten. Klicken
Sie auf stop und dann auf run, um
die Simulation neu zu starten.



